IPhone 3GS Is Not IOS 5 Compatible: Tweet

Posted: May 24 2011, 2:54pm CDT | by , in Rumors | Apple


iPhone 3GS is not iOS 5 Compatible: Tweet

It is anyway time to upgrade to an iPhone 5.

I still roll with an iPhone 3GS as I have a 2-yr contract I did not upgrade to an iPhone 4 when it came out. Now I do not want the iPhone 4 anymore and wait out until the iPhone 4S aka iPhone 5 comes out in September.

Eldar Martazin, the Russian analyst, with a lot of Nokia rumors under his belt, tweeted that the iPhone 3GS is not iOS 5 compatible. MacStories caught that tweet.

Apple already left behind the iPhone 3G. The iPhone 3GS is though still on sale and is the "bargain'' iPhone in the United States for $49 (w/ contract).

I honestly do not care as with the iOS 5 release comes a new iPhone. Those who jump on the $49 iPhone 3GS deal now should think twice about it though, unless they are fine with the current features.

You May Like


The Author

<a href="/latest_stories/all/all/2" rel="author">Luigi Lugmayr</a>
Luigi Lugmayr () is the founding chief Editor of I4U News and brings over 15 years experience in the technology field to the ever evolving and exciting world of gadgets. He started I4U News back in 2000 and evolved it into vibrant technology magazine.
Luigi can be contacted directly at ml@i4u.com.




Leave a Comment

Share this Story

Follow Us
Follow I4U News on Twitter
Follow I4U News on Facebook

You Also Like


Read the Latest from I4U News