<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en" dir="ltr" xmlns:fb="http://ogp.me/ns/fb#">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<script>window.mrf={host:"b.marfeel.com",dt:3},function(e,t,o,a,i,r,n){function d(){l&&(e.cookie="fromt=yes;path=/;expires="+new Date(Date.now()+18e5).toGMTString(),o.reload())}var l=!/marfeelgarda=no|fromt=yes/i.test(r+";"+i);if((/(ipad.*?OS )(?!1_|2_|3_|4_|X)|mozilla.*android (?!(1|2|3)\.)[0-9](?!.*mobile)|\bSilk\b/i.test(a)&&2&n.dt||/(ip(hone|od).*?OS )(?!1_|2_|3_|4_|X)|mozilla.*android (?!(1|2|3)\.)[0-9].*mobile|bb10/i.test(a)&&1&n.dt||/marfeelgarda=off/i.test(r))&&t===t.top){l&&e.write('<plaintext style="display:none">');var s="script",m=setTimeout(d,1e4),c=e.createElement(s),f=e.getElementsByTagName(s)[0];c.src="//bc.marfeel.com/statics/marfeel/gardac.js",c.onerror=d,c.onload=function(){clearTimeout(m)},f.parentNode.insertBefore(c,f)}}(document,window,location,navigator.userAgent,document.cookie,location.search,window.mrf);</script>
<meta charset="UTF-8">
<meta name="google-site-verification" content="w48BqQle7RGN3kk1eLzUpK_JQJeqff1g8vzKFeRD1Gk" />
<title>Splatoon 2 Nintendo Direct and the Best Splatoon 2 Deal Yet</title>
<script type="text/javascript">!function(){"use strict";function e(e,t,n){e.addEventListener?e.addEventListener(t,n,!1):e.attachEvent&&e.attachEvent("on"+t,n)}function t(e){return window.localStorage&&localStorage.font_css_cache&&localStorage.font_css_cache_file===e}function n(){if(window.localStorage&&window.XMLHttpRequest)if(t(o))c(localStorage.font_css_cache);else{var n=new XMLHttpRequest;n.open("GET",o,!0),e(n,"load",function(){4===n.readyState&&(c(n.responseText),localStorage.font_css_cache=n.responseText,localStorage.font_css_cache_file=o)}),n.send()}else{var a=document.createElement("link");a.href=o,a.rel="stylesheet",a.type="text/css",document.getElementsByTagName("head")[0].appendChild(a),document.cookie="font_css_cache"}}function c(e){var t=document.createElement("style");t.innerHTML=e,document.getElementsByTagName("head")[0].appendChild(t)}var o="/sites/all/themes/i4u/css/fonts/League_Gothic.css";window.localStorage&&localStorage.font_css_cache||document.cookie.indexOf("font_css_cache")>-1?n():e(window,"load",n)}();</script><noscript><link rel="stylesheet" href="https://static1.i4u.com/sites/all/themes/i4u/css/fonts/League_Gothic.css"></noscript>
<style>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</style>
<meta name="resource-type" content="document" />
<meta name="distribution" content="global" />
<meta name="author" content="I4U News" />
<meta name="copyright" content="copyright (c) 2003-2017 by I4U News" />
<meta name="google-site-verification" content="w48BqQle7RGN3kk1eLzUpK_JQJeqff1g8vzKFeRD1Gk" />
<meta name="keywords" content=":News,technology,deal,nintendo,best,direct,splatoon" />
<meta name="news_keywords" content=":News,technology,deal,nintendo,best,direct,splatoon" />


<meta name="rating" content="general" />
<meta name="robots" content="noydir,noodp">
<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.i4u.com/2017/07/123651/splatoon-2-nintendo-direct-and-best-splatoon-2-deal-yet"
  },
  
 "headline": "Splatoon 2 Nintendo Direct And The Best Splatoon 2 Deal Yet",   "image": {
    "@type": "ImageObject",
    "url": "https://static1.i4u.com/sites/default/files/imagecache/main_image_large/images/2017/07/splatoon-2-direct-deal.jpg",
    "height": 400,
    "width": 700
  },
  "datePublished": "2017-07-06T08:52:46-0500",
  "dateModified": "2017-07-06T08:52:51-0500",
  "author": {
    "@type": "Person",
    "name": "Luigi Lugmayr"
  },
  "publisher": {
    "@type": "Organization",
    "name": "I4U News",
    "logo": {
      "@type": "ImageObject",
      "url": "https://static2.i4u.com/sites/all/themes/i4u/images/2016/i4u-wide-google.png",
      "width": 600,
      "height": 60
    }
  },
  "description": "Splatoon 2 is the next big Nintendo Switch game release."
}
</script>



<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@i4unews">
<meta name="twitter:creator" content="@i4unews">
<meta name="twitter:title" content="Splatoon 2 Nintendo Direct and the Best Splatoon 2 Deal Yet">
<meta name="twitter:description" content="Splatoon 2 is the next big Nintendo Switch game release.">
<meta name="twitter:image" content="https://static1.i4u.com/sites/default/files/imagecache/main_image_large/images/2017/07/splatoon-2-direct-deal.jpg">
<meta property="fb:pages" content="98762478181" />
<meta property="article:publisher" content="https://www.facebook.com/i4ucommunity" />
<meta property="og:description" content="Splatoon 2 is the next big Nintendo Switch game release." />
<meta property="og:image" content="https://static1.i4u.com/sites/default/files/imagecache/main_image_large/images/2017/07/splatoon-2-direct-deal.jpg" />
<meta property="og:site_name" content="I4U News" />
<meta property="og:title" content="Splatoon 2 Nintendo Direct and the Best Splatoon 2 Deal Yet" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.i4u.com/2017/07/123651/splatoon-2-nintendo-direct-and-best-splatoon-2-deal-yet" />

<link rel="amphtml" href="https://amp.i4u.com/2017/07/123651/splatoon-2-nintendo-direct-and-best-splatoon-2-deal-yet">

<link rel="canonical" href="https://www.i4u.com/2017/07/123651/splatoon-2-nintendo-direct-and-best-splatoon-2-deal-yet" />

<link rel="alternate" type="application/rss+xml" title="RSS 2.0 feed" href="/i4u.xml" />

<script type="text/javascript">
function encrave()
{
if (typeof window.parent.postMessage !== 'undefined') {
  parent.postMessage("encaction","*");
}
}
</script>



  <!-- Prebid Config Section START -->
  <!-- Make sure this is inserted before your GPT tag -->
  <script> 
    var PREBID_TIMEOUT = 700;

    
    var adUnits = [{
        code: 'i4u-leaderboard',
        sizes: [[728, 90]],
        bids: [{
            bidder: 'appnexus',
            params: {
               placementId: '9973449'
            }
        }]
    },{
        code: 'i4u-billboard',
        sizes: [[970, 90], [970, 250]],
        bids: [{
            bidder: 'appnexus',
            params: {
               placementId: '9973449'
            }
        }]
        },{
        code: 'i4u-box',
        sizes: [[300, 250]],
        bids: [{
            bidder: 'appnexus',
            params: {
               placementId: '9973449'
            }
        }]
        },{
        code: 'i4u-boxauthor',
        sizes: [[300, 250]],
        bids: [{
            bidder: 'appnexus',
            params: {
               placementId: '9973449'
            }
        }]
        },{
        code: 'i4u-box1',
        sizes: [[300, 250]],
        bids: [{
            bidder: 'appnexus',
            params: {
               placementId: '9973449'
            }
        }]
        },{
        code: 'i4u-halfpage',
        sizes: [[300, 250], [300, 600]],
        bids: [{
            bidder: 'appnexus',
            params: {
               placementId: '9973449'
            }
        }]
        },{
        code: 'i4u-footer',
        sizes: [[728, 90]],
        bids: [{
            bidder: 'appnexus',
            params: {
               placementId: '9973449'
            }
        }]
             }];
    
    var pbjs = pbjs || {};
    pbjs.que = pbjs.que || [];

  </script>
  <!-- Prebid Config Section END -->
  
  <!-- Prebid Boilerplate Section START. No Need to Edit. -->
  <script type="text/javascript" src="https://static1.i4u.com/sites/all/themes/i4u/js/prebid.js" async></script>
  <script>
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    googletag.cmd.push(function() {
        googletag.pubads().disableInitialLoad();
    });

    pbjs.que.push(function() {
        pbjs.addAdUnits(adUnits);
        pbjs.requestBids({
            bidsBackHandler: sendAdserverRequest
        });
    });

    function sendAdserverRequest() {
        if (pbjs.adserverRequestSent) return;
        pbjs.adserverRequestSent = true;
        googletag.cmd.push(function() {
            pbjs.que.push(function() {
                pbjs.setTargetingForGPTAsync();
                googletag.pubads().refresh();
            });
        });
    }

    setTimeout(function() {
        sendAdserverRequest();
    }, PREBID_TIMEOUT);

  </script>
  <!-- Prebid Boilerplate Section END -->


<!-- BEGIN Krux ControlTag for "i4u" -->
<script class="kxct" data-id="q82f71yvg" data-timing="async" data-version="3.0" type="text/javascript">
  window.Krux||((Krux=function(){Krux.q.push(arguments)}).q=[]);
  (function(){
    var k=document.createElement('script');k.type='text/javascript';k.async=true;
    k.src=(location.protocol==='https:'?'https:':'http:')+'//cdn.krxd.net/controltag/q82f71yvg.js';
    var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
  }());
</script>
<!-- END Krux ControlTag -->

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/5611/i4u', [[728, 90]], 'i4u-leaderboard').addService(googletag.pubads());
    googletag.defineSlot('/5611/i4u', [[300, 250]], 'i4u-box').addService(googletag.pubads());
    googletag.defineSlot('/5611/i4u', [[300, 250]], 'i4u-boxauthor').addService(googletag.pubads());
     googletag.defineSlot('/5611/i4u', [[300, 250]], 'i4u-box1').addService(googletag.pubads());
    googletag.defineSlot('/5611/i4u', [[300, 250], [300, 600] ], 'i4u-halfpage').addService(googletag.pubads());
    googletag.defineSlot('/5611/i4u', [[728, 90]], 'i4u-footer').addService(googletag.pubads());
    googletag.defineSlot('/5611/i4u', [[970, 90], [970, 250]], 'i4u-billboard').addService(googletag.pubads());
    
        googletag.defineOutOfPageSlot('/5611/i4u', 'i4u-outofpage').addService(googletag.pubads());
    
    
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>




<!--  DistroScale  -->
<script async type="text/javascript" src="//c.jsrdn.com/s/cs.js?p=22428"> </script>
 
  </head>
<body>




<script>
  dataLayer = [];
</script>
<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-M5C6SD"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-M5C6SD');</script>
<!-- End Google Tag Manager -->


<div id='i4u-outofpage'>
<script>
googletag.cmd.push(function() { googletag.display('i4u-outofpage'); });
</script>
</div>


<div class="container">
	
		

	<div id="header">
		<a href="/" class="logoLink"><div id='Logo'></div></a>
    	<div id="TopPromo" style="border: 1px solid #d3d3d3;">
	
	<div id='i4u-leaderboard'>
<script>
googletag.cmd.push(function() { googletag.display('i4u-leaderboard'); });
</script>
</div>

	</div>
	</div>
	

	<div id="TopNav" class="clearfix">
		<div id="desktop_menu"> 
<div id="block-menu-menu-global" class=""><div class="block-inner">

  
  <div class="content">
    <ul class="menu"><li class="leaf first"><a href="/47/technology-news" title="">Tech</a></li>
<li class="leaf"><a href="/51/apple" title="">Apple</a></li>
<li class="leaf"><a href="/92652/latest-science-news" title="">Science</a></li>
<li class="leaf"><a href="/55/cars-vehicles" title="">Cars</a></li>
<li class="leaf"><a href="/tag/switch" title="">Nintendo Switch</a></li>
<li class="leaf"><a href="/tag/iphone" title="">iPhone 7S &amp; 8</a></li>
<li class="leaf"><a href="/tag/prime" title="">Prime Day 2017</a></li>
<li class="leaf last"><a href="/tag/snes" title="">SNES Classic</a></li>
</ul>  </div>

  
</div></div> <!-- /block-inner, /block -->
 </div>		
	</div>

	 <div style="height: 5px;">&nbsp;</div>	
	<center>	


	<div id='i4u-billboard'>
<script>
googletag.cmd.push(function() { googletag.display('i4u-billboard'); });
</script>
</div>
	
</center>
<div style="height: 5px;">&nbsp;</div>	
	<a name="top_anchor" id="top_anchor"></a>
		  
		<div class="clearfix titleArea">
			<h1>Splatoon 2 Nintendo Direct And The Best Splatoon 2 Deal Yet</h1>						<p id="DateAndAuthor" class="titleArea-dateAndAuthor">
				Posted: Jul 6 2017, 8:52am CDT | by <a href="/latest_stories/all/all/2" rel="author">Luigi Lugmayr</a>, in <a href="/news">News</a> | <a href="/47/technology-news">Technology News</a>				
				<div style="height: 3px;">&nbsp;</div>
				
			</p>
			

			
			
					
								 
		
	

	
	<div id="PageContainer"> 
				<div id="MainContent">
		  


	<div class="clearfix">
		
		<!-- main column -->
		<div class="two-thirds column alpha content largeImage">

<!-- ad disabled, enable before Prime Day -->

			<div id="titleseed" style="display:none"></div> 



			<!-- Top image -->
			<div class="clearfix">
				<div id="mainPic" class="Left">
											<div>
							 
							<img src="https://static1.i4u.com/sites/default/files/imagecache/main_image_large/images/2017/07/splatoon-2-direct-deal.jpg" alt="Splatoon 2 Nintendo Direct and the Best Splatoon 2 Deal Yet" title=""  />							
													</div>
														</div>
							</div>
			
			
		
			
			
						<div>
							</div>
			 
			<span class="mrf-hide"> 
		<ul class="share-buttons">
  <li><a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.i4u.com&t=" title="Share on Facebook" target="_blank" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u=' + encodeURIComponent(document.URL) + '&t=' + encodeURIComponent(document.URL)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Facebook.svg"></a></li>
  <li><a href="https://twitter.com/intent/tweet?source=http%3A%2F%2Fwww.i4u.com&text=:%20http%3A%2F%2Fwww.i4u.com&via=i4unews" target="_blank" title="Tweet" onclick="window.open('https://twitter.com/intent/tweet?text=' + encodeURIComponent(document.title) + ':%20'  + encodeURIComponent(document.URL)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Twitter.svg"></a></li>
  <li><a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.i4u.com" target="_blank" title="Share on Google+" onclick="window.open('https://plus.google.com/share?url=' + encodeURIComponent(document.URL)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Google+.svg"></a></li>
  <li><a href="http://www.tumblr.com/share?v=3&u=http%3A%2F%2Fwww.i4u.com&t=&s=" target="_blank" title="Post to Tumblr" onclick="window.open('http://www.tumblr.com/share?v=3&u=' + encodeURIComponent(document.URL) + '&t=' +  encodeURIComponent(document.title)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Tumblr.svg"></a></li>
  <li><a href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.i4u.com&description=" target="_blank" title="Pin it" onclick="window.open('http://pinterest.com/pin/create/button/?url=' + encodeURIComponent(document.URL) + '&description=' +  encodeURIComponent(document.title)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Pinterest.svg"></a></li>
  <li><a href="http://www.reddit.com/submit?url=http%3A%2F%2Fwww.i4u.com&title=" target="_blank" title="Submit to Reddit" onclick="window.open('http://www.reddit.com/submit?url=' + encodeURIComponent(document.URL) + '&title=' +  encodeURIComponent(document.title)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Reddit.svg"></a></li>
  <li><a href="http://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.i4u.com&title=&summary=&source=http%3A%2F%2Fwww.i4u.com" target="_blank" title="Share on LinkedIn" onclick="window.open('https://www.linkedin.com/shareArticle?mini=true&url=' + encodeURIComponent(document.URL) + '&title=' +  encodeURIComponent(document.title)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/LinkedIn.svg"></a></li>
  <li><a href="mailto:?subject=&body=:%20http%3A%2F%2Fwww.i4u.com" target="_blank" title="Email" onclick="window.open('mailto:?subject=' + encodeURIComponent(document.title) + '&body=' +  encodeURIComponent(document.URL)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Email.svg"></a></li>
</ul>
</span>

	<div style="height: 4px;">&nbsp;</div>
	
	
	     
     	
     	
		
	
			<div itemprop="articleBody">
				<h2>Splatoon 2 is the next big Nintendo Switch game release.</h2> 		
				
					<div id="StoryBody">
					
				<p>The online stream of the Splatoon 2 Direct will begin at shortly at 7am PT / 10am ET. The new Nintendo Direct session will show off new features in the new Splatoon 2 game hitting the Nintendo Switch on July 21. Amazon has sold out of Splatoon 2 ahead of the Nintendo Direct. This <strong><a href="https://www.i4u.com/2017/07/123630/nintendo-switch-splatoon-2-4777-amazon-without-prime-membership" target="_blank">happened after Amazon offered the 20% discount on Splatoon 2 to all customers</a></strong>, not just Prime members starting yesterday.</p><p class='MoreLink' style='margin-left: 10px;'><strong>Don't Miss:&nbsp;<a href='http://amzn.to/2lq6z1m' target='_blank'>Today's Best Deals on Amazon.com</a></strong></p><p>Walmart has a <strong><a href="http://bit.ly/2ttGiku" target="_blank">deal on Splatoon 2</a></strong> that beats Amazon's deal when you opt to pick up the game at your local Walmart store. Walmart is selling Splatoon 2 with in store pickup for $46.8 online at <strong><a href="http://bit.ly/2ttGiku" target="_blank">walmart.com</a></strong>.</p><p>The Nintendo Direct stream is available at the Nintendo Direct page on <a href="http://www.nintendo.com/nintendo-direct/07-06-2017/" target="_blank">nintendo.com</a>, <a href="https://www.youtube.com/watch?v=ffK1_X160DA" target="_blank">Youtube</a> and on <a href="https://www.twitch.tv/nintendo" target="_blank">twitch</a>.<p style="text-align: left;"><strong>About Splatoon 2:</strong> Two years have passed since the original Splatoon game was released, and two years have also passed in Inkopolis! So expect a fresh wave of fashion, not to mention new weapons and gear. Dual wield the new Splat Dualies or stick to mainstays like chargers and rollers, which have been remixed with new strategic possibilities.<p style="text-align: left;">As always, Turf War is the favored sport among Inklings, but they also dig ranked battles, taking down Octarians in a robust single-player campaign, and battling enemy Salmonids in one dangerous part-time job! No matter which way you play, splat at home or on-the-go with Nintendo Switch. Staying fresh never felt so good.&nbsp;<p style="text-align: left;">The Nintendo Switch is back in stock online. Read the <strong><a href="https://www.i4u.com/2017/07/123650/nintendo-switch-stock-update-july-6" target="_blank">latest Nintendo Switch availability report</a></strong>.</p>				
				
		
			
				
					</div>
			</div>
															
						
			
						
<p style="font-size:10px;font-color:eee;">
			This story may contain affiliate links.
</p>			
			 <p>
			 <div style="width:610px;">
			 
 
<div class="OUTBRAIN" data-src="https://www.i4u.com/2017/07/123651/splatoon-2-nintendo-direct-and-best-splatoon-2-deal-yet" data-widget-id="AR_1" data-ob-template="i4u.com"></div> 
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>



</div>
</p>
			 
			 <p>
			 <a href="#disqus_thread">Comments</a>
			 </p>
			 
			
			 
			 
			 
			
			
			
			
	



<div>
<div style="float:left;text-align:top;width:295px;">

 <h3 class="impactHeader">
						<span class="impactHeader-bg">The Author</span>
					</h3>
					<p id="AuthorBio"><a href="/latest_stories/all/all/2"><img src="https://static1.i4u.com/sites/default/files/imagecache/authorbio_pic/user_images/picture-2.jpg" alt="&lt;a href=&quot;/latest_stories/all/all/2&quot; rel=&quot;author&quot;&gt;Luigi Lugmayr&lt;/a&gt;" title=""  width="80" height="80" /></a><strong><a href="/latest_stories/all/all/2" rel="author">Luigi Lugmayr</a></strong><br />Luigi Lugmayr (<a href="https://plus.google.com/+LuigiLugmayr" rel="author" target="_blank">Google+</a>) is the founding chief Editor of <a href="https://plus.google.com/103093213973713984393" rel="publisher" target="_blank">I4U News</a> and brings over 15 years
experience in the technology field to the ever evolving and exciting
world of gadgets. He started I4U News back in 2000 and evolved it into
vibrant technology magazine.<br>
Luigi can be contacted directly at ml@i4u.com. <div class="Clear">&nbsp;</div></p>
</div>
<div style="float:left;width:10px;">&nbsp;</div>	
<div style="float:left">	
 <h3 class="impactHeader">
						<span class="impactHeader-bg">Advertisement</span>
					</h3>


<div style="width:300px;height:250px;">    

<div id='i4u-boxauthor'>
<script>
googletag.cmd.push(function() { googletag.display('i4u-boxauthor'); });
</script>
</div>

</div>



</div>


<div style="clear:both"></div>
</div>

			
 		  
	<span class="mrf-hide">
 <ul class="share-buttons" style="list-style:none;">
  <li><a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.i4u.com&t=" title="Share on Facebook" target="_blank" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u=' + encodeURIComponent(document.URL) + '&t=' + encodeURIComponent(document.URL)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Facebook.svg"></a></li>
  <li><a href="https://twitter.com/intent/tweet?source=http%3A%2F%2Fwww.i4u.com&text=:%20http%3A%2F%2Fwww.i4u.com&via=i4unews" target="_blank" title="Tweet" onclick="window.open('https://twitter.com/intent/tweet?text=' + encodeURIComponent(document.title) + ':%20'  + encodeURIComponent(document.URL)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Twitter.svg"></a></li>
  <li><a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.i4u.com" target="_blank" title="Share on Google+" onclick="window.open('https://plus.google.com/share?url=' + encodeURIComponent(document.URL)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Google+.svg"></a></li>
  <li><a href="http://www.tumblr.com/share?v=3&u=http%3A%2F%2Fwww.i4u.com&t=&s=" target="_blank" title="Post to Tumblr" onclick="window.open('http://www.tumblr.com/share?v=3&u=' + encodeURIComponent(document.URL) + '&t=' +  encodeURIComponent(document.title)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Tumblr.svg"></a></li>
  <li><a href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.i4u.com&description=" target="_blank" title="Pin it" onclick="window.open('http://pinterest.com/pin/create/button/?url=' + encodeURIComponent(document.URL) + '&description=' +  encodeURIComponent(document.title)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Pinterest.svg"></a></li>
  <li><a href="http://www.reddit.com/submit?url=http%3A%2F%2Fwww.i4u.com&title=" target="_blank" title="Submit to Reddit" onclick="window.open('http://www.reddit.com/submit?url=' + encodeURIComponent(document.URL) + '&title=' +  encodeURIComponent(document.title)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Reddit.svg"></a></li>
  <li><a href="http://www.linkedin.com/shareArticle?mini=true&url=http%3A%2F%2Fwww.i4u.com&title=&summary=&source=http%3A%2F%2Fwww.i4u.com" target="_blank" title="Share on LinkedIn" onclick="window.open('http://www.linkedin.com/shareArticle?mini=true&url=' + encodeURIComponent(document.URL) + '&title=' +  encodeURIComponent(document.title)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/LinkedIn.svg"></a></li>
  <li><a href="mailto:?subject=&body=:%20http%3A%2F%2Fwww.i4u.com" target="_blank" title="Email" onclick="window.open('mailto:?subject=' + encodeURIComponent(document.title) + '&body=' +  encodeURIComponent(document.URL)); return false;"><img src="https://static2.i4u.com/sites/all/themes/i4u/images/global/social_flat_rounded_rects_svg/Email.svg"></a></li>
</ul>
</span>		  
			  
			
			
	

			
			<h3 class='impactHeader'><span class="impactHeader-bg">Latest News</span></h3>
			<div class="teaserGrid--3cols">
				<div class='row'><div class='teaserGrid-col teaserGrid-cols--1 teaserGrid-First'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123650/nintendo-switch-stock-update-july-6" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/05/tracker-nintendo-switch-report-may-19.jpg" alt="Nintendo Switch Stock Update for July 6" title=""  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123650/nintendo-switch-stock-update-july-6">Nintendo Switch Stock Update for July 6</a></h3>
		<p><span class='Date HoursOld'>23 minutes ago</span></p>
	</div>
</div>
<!-- time{1499347778} -->
<!-- id{123650} -->
	</div>
</div><div class='teaserGrid-col teaserGrid-cols--1'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123648/top-25-nintendo-switch-games-2017" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/nintendo-switch-games.jpg" alt="Top 25 Nintendo Switch Games for 2017" title=""  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123648/top-25-nintendo-switch-games-2017">Top 25 Nintendo Switch Games for 2017</a></h3>
		<p><span class='Date HoursOld'>1 hour ago</span></p>
	</div>
</div>
<!-- time{1499345214} -->
<!-- id{123648} -->
	</div>
</div><div class='teaserGrid-col teaserGrid-cols--1 teaserGrid-Last'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123646/nintendo-switch-getting-wonderful-101" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/nintendo-switch-wonderful-101.jpg" alt="Nintendo Switch is Getting Wonderful 101" title=""  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123646/nintendo-switch-getting-wonderful-101">Nintendo Switch is Getting Wonderful 101</a></h3>
		<p><span class='Date HoursOld'>1 hour ago</span></p>
	</div>
</div>
<!-- time{1499344599} -->
<!-- id{123646} -->
	</div>
</div></div><div class='row'><div class='teaserGrid-col teaserGrid-cols--1 teaserGrid-First'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123643/nintendo-says-there-are-more-unannounced-switch-games-coming" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/switch-game.jpg" alt="Nintendo Says there are More Unannounced Switch Games Coming" title="Image via Gamespot"  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123643/nintendo-says-there-are-more-unannounced-switch-games-coming">Nintendo Says there are More Unannounced Switch Games Coming</a></h3>
		<p><span class='Date HoursOld'>3 hours ago</span></p>
	</div>
</div>
<!-- time{1499338155} -->
<!-- id{123643} -->
</div>
</div><div class='teaserGrid-col teaserGrid-cols--1'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123649/apollo-teases-all-new-ie-hypercar" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/apolloiehypercar.jpg" alt="Apollo Teases All-New IE Hypercar" title=""  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123649/apollo-teases-all-new-ie-hypercar">Apollo Teases All-New IE Hypercar</a>		</h3>
		<p><span class='Date HoursOld'>47 minutes ago</span></p>
	</div>

</div>
<!-- time{1499346311} -->
<!-- id{123649} -->
	</div>
</div><div class='teaserGrid-col teaserGrid-cols--1 teaserGrid-Last'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123647/2018-iphones-have-all-oled-displays" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/iphone8-rumor.jpg" alt="2018 iPhones Have All OLED Displays" title="Credit: @VenyaGeskin1"  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123647/2018-iphones-have-all-oled-displays">2018 iPhones Have All OLED Displays</a>		</h3>
		<p><span class='Date HoursOld'>1 hour ago</span></p>
	</div>

</div>
<!-- time{1499344807} -->
<!-- id{123647} -->
	</div>
</div></div><div class='row'><div class='teaserGrid-col teaserGrid-cols--1 teaserGrid-First'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123645/prime-day-2017-apple-deals-how-find-them" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/prime-day-2017-apple-deals.jpg" alt="Prime Day 2017 Apple Deals: How to Find Them" title=""  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123645/prime-day-2017-apple-deals-how-find-them">Prime Day 2017 Apple Deals: How to Find Them</a>		</h3>
		<p><span class='Date HoursOld'>1 hour ago</span></p>
	</div>

</div>
<!-- time{1499342744} -->
<!-- id{123645} -->
	</div>
</div><div class='teaserGrid-col teaserGrid-cols--1'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123644/2018-nissan-leaf-adds-propilot-park-autonomous-parking" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/nissan-leaf-self-parking.jpg" alt="2018 Nissan Leaf Adds ProPILOT Park for Autonomous Parking" title=""  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123644/2018-nissan-leaf-adds-propilot-park-autonomous-parking">2018 Nissan Leaf Adds ProPILOT Park for Autonomous Parking</a>		</h3>
		<p><span class='Date HoursOld'>2 hours ago</span></p>
	</div>

</div>
<!-- time{1499340925} -->
<!-- id{123644} -->
	</div>
</div><div class='teaserGrid-col teaserGrid-cols--1 teaserGrid-Last'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123642/some-google-pixel-smartphones-fail-installing-july-2017-ota-update" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/google-pixel.jpg" alt="Some Google Pixel Smartphones Fail at Installing July 2017 OTA Update" title="Image via Google"  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123642/some-google-pixel-smartphones-fail-installing-july-2017-ota-update">Some Google Pixel Smartphones Fail at Installing July 2017 OTA Update</a>		</h3>
		<p><span class='Date HoursOld'>3 hours ago</span></p>
	</div>

</div>
<!-- time{1499337092} -->
<!-- id{123642} -->
	</div>
</div></div><div class='row'><div class='teaserGrid-col teaserGrid-cols--1 teaserGrid-First'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123641/prime-day-2017-break-records-small-businesses-and-entrepreneurs" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/prime-day-2017-success-stories.jpg" alt="Prime Day 2017 To break Records for Small Businesses and Entrepreneurs" title="Credit: Amazon"  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123641/prime-day-2017-break-records-small-businesses-and-entrepreneurs">Prime Day 2017 To break Records for Small Businesses and Entrepreneurs</a>		</h3>
		<p><span class='Date HoursOld'>3 hours ago</span></p>
	</div>

</div>
<!-- time{1499336043} -->
<!-- id{123641} -->
	</div>
</div><div class='teaserGrid-col teaserGrid-cols--1'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123640/tesla-responds-model-s-iihs-crash-test-rating" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/teslamodelsiihscrashtest.jpg" alt="Tesla Responds to Model S IIHS Crash Test Rating" title=""  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123640/tesla-responds-model-s-iihs-crash-test-rating">Tesla Responds to Model S IIHS Crash Test Rating</a>		</h3>
		<p><span class='Date HoursOld'>3 hours ago</span></p>
	</div>

</div>
<!-- time{1499335331} -->
<!-- id{123640} -->
	</div>
</div><div class='teaserGrid-col teaserGrid-cols--1 teaserGrid-Last'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123620/nintendo-snes-classic-game-contra-iii-alien-wars" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/snes-contra-iii-alien-wars.jpg" alt="Nintendo SNES Classic Game Contra III: The Alien Wars" title=""  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123620/nintendo-snes-classic-game-contra-iii-alien-wars">Nintendo SNES Classic Game Contra III: The Alien Wars</a>		</h3>
		<p><span class='Date HoursOld'>4 hours ago</span></p>
	</div>

</div>
<!-- time{1499334751} -->
<!-- id{123620} -->
	</div>
</div></div><div class='row'><div class='teaserGrid-col teaserGrid-cols--1 teaserGrid-First'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123639/snes-classic-pre-order-one-store-europe-not-sold-out" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/snes-classic-pre-order-europe-ch.jpg" alt="SNES Classic Pre-order: One Store in Europe is Not Sold Out" title=""  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123639/snes-classic-pre-order-one-store-europe-not-sold-out">SNES Classic Pre-order: One Store in Europe is Not Sold Out</a>		</h3>
		<p><span class='Date HoursOld'>4 hours ago</span></p>
	</div>

</div>
<!-- time{1499334528} -->
<!-- id{123639} -->
	</div>
</div><div class='teaserGrid-col teaserGrid-cols--1'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123638/nintendo-switch-neon-green-and-pink-joy-con-are-available-pre-order" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/splatoon-joy-con-buy.jpg" alt="Nintendo Switch Neon Green and Pink Joy-Con Are Available for Pre-order" title=""  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123638/nintendo-switch-neon-green-and-pink-joy-con-are-available-pre-order">Nintendo Switch Neon Green and Pink Joy-Con Are Available for Pre-order</a>		</h3>
		<p><span class='Date HoursOld'>4 hours ago</span></p>
	</div>

</div>
<!-- time{1499333078} -->
<!-- id{123638} -->
	</div>
</div><div class='teaserGrid-col teaserGrid-cols--1 teaserGrid-Last'><div class="stream_item teaser_card">
		
<div class="teaserCard">
	<div>
		<a href="/2017/07/123637/amazon-prime-day-2017-schedule-best-times-score-deals" class="imagecache imagecache-teasercards_thumb imagecache-linked imagecache-teasercards_thumb_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/teasercards_thumb/images/2017/07/prime-day-2017-schedule-hour.jpg" alt="Amazon Prime Day 2017 Schedule: Best Times to Score Deals" title=""  width="240" height="160" /></a>	</div>
	<div class="teaserCard-text">
		<h3><a href="/2017/07/123637/amazon-prime-day-2017-schedule-best-times-score-deals">Amazon Prime Day 2017 Schedule: Best Times to Score Deals</a>		</h3>
		<p><span class='Date HoursOld'>4 hours ago</span></p>
	</div>

</div>
<!-- time{1499331445} -->
<!-- id{123637} -->
	</div>
</div></div>			</div>
			
			
						<div class="mrf-hide">

	 <a name="disqus_thread" id="disqus_thread"></a>
		
			<p id="Comments">
				<div id="disqus_thread"></div>
					<script type="text/javascript">
						
						var disqus_url='https://www.i4u.com/2017/07/123651/splatoon-2-nintendo-direct-and-best-splatoon-2-deal-yet';
						var disqus_identifier= 123651;
				
						 (function() {
						 var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
						 dsq.src = 'https://i4unews.disqus.com/embed.js';
						 (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
						})();
					</script>
					<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript=i4unews">comments powered by Disqus.</a></noscript>
					<a href="https://disqus.com" class="dsq-brlink">comments powered by <span class="logo-disqus">Disqus</span></a>
					</p> 
					
				
         </div>                       
					
		
	





			
			

			
		</div>
		<!-- /main column -->
		
		<!-- sidebar -->
		<div class="one-third column omega">
		
		
		

			
		
		<div style="border: 1px solid #d3d3d3;width:300px;height:250px;">
		<div id='i4u-box'>
<script>
googletag.cmd.push(function() { googletag.display('i4u-box'); });
</script>
</div>
		</div>
		
			



<BR>
 			   
			 
 <div style="width:300px;">

<a href="https://www.i4u.com/2017/05/122634/tracker-app-i4u-news-app-finds-rare-products-stock-online" target="_blank"><img src="https://static2.i4u.com/sites/default/files/images/content_images/tracker-stock-download-app.jpg" alt="The Tracker by I4U News" width="300" height="120" /></a>

</div>
<BR>

			
			<!-- Featured stories -->
			<h3 class="impactHeader"><span class="impactHeader-bg">Featured News</span></h3>
			<div class="featuredTeasers clearfix">
				<div class="Left">
	<a href="/2017/06/123539/prime-day-2017-announced" class="imagecache imagecache-home_highlight_right imagecache-linked imagecache-home_highlight_right_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/home_highlight_right/images/2017/06/prime-day-2017-date-deals-official.jpg" alt="Prime Day 2017 Announced" title=""  width="146" height="111" /></a>	<p><a href="/2017/06/123539/prime-day-2017-announced">Prime Day 2017 Announced</a></p>
</div>

<div class="Right">
	<a href="/2017/06/123519/snes-classic-listed-walmart-amazon-and-best-buy" class="imagecache imagecache-home_highlight_right imagecache-linked imagecache-home_highlight_right_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/home_highlight_right/images/2017/06/tracker-super-nes-class-edition-stock-update.jpg" alt="SNES Classic Is Listed at Walmart, Amazon and Best Buy" title=""  width="146" height="111" /></a>	<p><a href="/2017/06/123519/snes-classic-listed-walmart-amazon-and-best-buy">SNES Classic Is Listed at Walmart, Amazon and Best Buy</a></p>
</div>

	<div class="Clear">&nbsp;</div>
<div class="Left">
	<a href="/2017/06/123229/win-free-nintendo-switch-console-tracker-i4u-news-summer-giveaway" class="imagecache imagecache-home_highlight_right imagecache-linked imagecache-home_highlight_right_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/home_highlight_right/images/2017/06/tracker-nintendo-switch-gray-joy-con-giveaway.jpg" alt="Win a Free Nintendo Switch Console in The Tracker by I4U News Summer Giveaway" title="Nintendo Switch Summer Giveaway at I4U News"  width="146" height="111" /></a>	<p><a href="/2017/06/123229/win-free-nintendo-switch-console-tracker-i4u-news-summer-giveaway">Win a Free Nintendo Switch Console in The Tracker by I4U News Summer Giveaway</a></p>
</div>

<div class="Right">
	<a href="/2017/06/123551/prime-day-2017-announcement-big-take-aways" class="imagecache imagecache-home_highlight_right imagecache-linked imagecache-home_highlight_right_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/home_highlight_right/images/2017/06/top-10-prime-day-2017.jpg" alt="Prime Day 2017 Announcement: The Big Take Aways" title=""  width="146" height="111" /></a>	<p><a href="/2017/06/123551/prime-day-2017-announcement-big-take-aways">Prime Day 2017 Announcement: The Big Take Aways</a></p>
</div>

			</div>
			<BR>
			 
			
			<!-- ad -->
			<BR>
		 <div style="border: 1px solid #d3d3d3;">
		 <div id='i4u-halfpage'>
		<script>
		googletag.cmd.push(function() { googletag.display('i4u-halfpage'); });
		</script>
		</div>
		</div>
		


<BR>
			
			<!-- latest from main topic -->
						<div class="sidebarLatest">
				<h3 class="impactHeader"><span class="impactHeader-bg">Technology News</span></h3>
<div class="sidebarLatest-story">
  <p><a href="/2017/07/123650/nintendo-switch-stock-update-july-6" class="imagecache imagecache-see_also_300x121 imagecache-linked imagecache-see_also_300x121_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/see_also_300x121/images/2017/05/tracker-nintendo-switch-report-may-19.jpg" alt="Nintendo Switch Stock Update for July 6" title=""  width="300" height="121" /></a></p>
  <p>
    <strong><a href="/2017/07/123650/nintendo-switch-stock-update-july-6">Nintendo Switch Stock Update for July 6</a></strong>
    <br />
   
  </p>
  <p class="sidebarLatest-date">
     <span class='Date HoursOld'>23 minutes ago</span>  </p>
</div>

<div class="sidebarLatest-story">
  <p><a href="/2017/07/123648/top-25-nintendo-switch-games-2017" class="imagecache imagecache-see_also_300x121 imagecache-linked imagecache-see_also_300x121_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/see_also_300x121/images/2017/07/nintendo-switch-games.jpg" alt="Top 25 Nintendo Switch Games for 2017" title=""  width="300" height="121" /></a></p>
  <p>
    <strong><a href="/2017/07/123648/top-25-nintendo-switch-games-2017">Top 25 Nintendo Switch Games for 2017</a></strong>
    <br />
   
  </p>
  <p class="sidebarLatest-date">
     <span class='Date HoursOld'>1 hour ago</span>  </p>
</div>

<div class="sidebarLatest-story">
  <p><a href="/2017/07/123646/nintendo-switch-getting-wonderful-101" class="imagecache imagecache-see_also_300x121 imagecache-linked imagecache-see_also_300x121_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/see_also_300x121/images/2017/07/nintendo-switch-wonderful-101.jpg" alt="Nintendo Switch is Getting Wonderful 101" title=""  width="300" height="121" /></a></p>
  <p>
    <strong><a href="/2017/07/123646/nintendo-switch-getting-wonderful-101">Nintendo Switch is Getting Wonderful 101</a></strong>
    <br />
   
  </p>
  <p class="sidebarLatest-date">
     <span class='Date HoursOld'>1 hour ago</span>  </p>
</div>

<div class="sidebarLatest-story">
  <p><a href="/2017/07/123643/nintendo-says-there-are-more-unannounced-switch-games-coming" class="imagecache imagecache-see_also_300x121 imagecache-linked imagecache-see_also_300x121_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/see_also_300x121/images/2017/07/switch-game.jpg" alt="Nintendo Says there are More Unannounced Switch Games Coming" title="Image via Gamespot"  width="300" height="121" /></a></p>
  <p>
    <strong><a href="/2017/07/123643/nintendo-says-there-are-more-unannounced-switch-games-coming">Nintendo Says there are More Unannounced Switch Games Coming</a></strong>
    <br />
   
  </p>
  <p class="sidebarLatest-date">
     <span class='Date HoursOld'>3 hours ago</span>  </p>
</div>
<p class="MoreLink">
	<a href="/47/technology-news">More Technology News Stories</a></p>

			</div>
			<br />
						<Br>
			

<div class="OUTBRAIN" data-src="https://www.i4u.com/2017/07/123651/splatoon-2-nintendo-direct-and-best-splatoon-2-deal-yet" data-widget-id="AR_2" data-ob-template="i4u.com"></div> 
<script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
	<BR>

			
		
 <div style="border: 1px solid #d3d3d3;">
		<div id='i4u-box1'>
<script>
googletag.cmd.push(function() { googletag.display('i4u-box1'); });
</script>
</div>
</div>
			

<!-- latest -->
			<div class="sidebarLatest">
				<h3 class="impactHeader"><span class="impactHeader-bg">Latest News</span></h3>
				<div class="sidebarLatest-story">
  <p><a href="/2017/07/123650/nintendo-switch-stock-update-july-6" class="imagecache imagecache-see_also_300x121 imagecache-linked imagecache-see_also_300x121_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/see_also_300x121/images/2017/05/tracker-nintendo-switch-report-may-19.jpg" alt="Nintendo Switch Stock Update for July 6" title=""  width="300" height="121" /></a></p>
  <p>
    <strong><a href="/2017/07/123650/nintendo-switch-stock-update-july-6">Nintendo Switch Stock Update for July 6</a></strong>
    <br />
   
  </p>
  <p class="sidebarLatest-date">
     <span class='Date HoursOld'>23 minutes ago</span>  </p>
</div>
<div class="sidebarLatest-story">
  <p><a href="/2017/07/123649/apollo-teases-all-new-ie-hypercar" class="imagecache imagecache-see_also_300x121 imagecache-linked imagecache-see_also_300x121_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/see_also_300x121/images/2017/07/apolloiehypercar.jpg" alt="Apollo Teases All-New IE Hypercar" title=""  width="300" height="121" /></a></p>
  <p>
    <strong><a href="/2017/07/123649/apollo-teases-all-new-ie-hypercar">Apollo Teases All-New IE Hypercar</a></strong>
    <br />
   
  </p>
  <p class="sidebarLatest-date">
     <span class='Date HoursOld'>47 minutes ago</span>  </p>
</div>
<div class="sidebarLatest-story">
  <p><a href="/2017/07/123648/top-25-nintendo-switch-games-2017" class="imagecache imagecache-see_also_300x121 imagecache-linked imagecache-see_also_300x121_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/see_also_300x121/images/2017/07/nintendo-switch-games.jpg" alt="Top 25 Nintendo Switch Games for 2017" title=""  width="300" height="121" /></a></p>
  <p>
    <strong><a href="/2017/07/123648/top-25-nintendo-switch-games-2017">Top 25 Nintendo Switch Games for 2017</a></strong>
    <br />
   
  </p>
  <p class="sidebarLatest-date">
     <span class='Date HoursOld'>1 hour ago</span>  </p>
</div>
<div class="sidebarLatest-story">
  <p><a href="/2017/07/123647/2018-iphones-have-all-oled-displays" class="imagecache imagecache-see_also_300x121 imagecache-linked imagecache-see_also_300x121_linked"><img src="https://static1.i4u.com/sites/default/files/imagecache/see_also_300x121/images/2017/07/iphone8-rumor.jpg" alt="2018 iPhones Have All OLED Displays" title="Credit: @VenyaGeskin1"  width="300" height="121" /></a></p>
  <p>
    <strong><a href="/2017/07/123647/2018-iphones-have-all-oled-displays">2018 iPhones Have All OLED Displays</a></strong>
    <br />
   
  </p>
  <p class="sidebarLatest-date">
     <span class='Date HoursOld'>1 hour ago</span>  </p>
</div>
				<p class="MoreLink">
					<a href="/latest">More Latest News</a>
				</p>
			</div>

 <BR>
 			   
			 
 <div style="width:300px;">

<a href="https://www.i4u.com/thetracker/products/" target="_blank"><img src="https://static2.i4u.com/sites/default/files/images/content_images/tracker-stock-download-app.jpg" alt="The Tracker by I4U News" width="300" height="120" /></a>

</div>
<div style="width:300px;" class="sidebarLatest">
<h3 class="impactHeader"><span class="impactHeader-bg">Popular Products</span></h3>	
<p><B><a href='https://www.i4u.com/thetracker/products/tracker-2.html'>Nintendo Switch with Gray Joy-Con</a></b>  <img src="https://static2.i4u.com/thetracker/products/images/outofstock-20.png" class="instock" style="height:20px;vertical-align:middle" alt="Nintendo Switch with Gray Joy-Con  is out of Stock"><BR></p><p><B><a href='https://www.i4u.com/thetracker/products/tracker-3.html'>Nintendo Switch with Neon Joy-Con</a></b>  <img src="https://static2.i4u.com/thetracker/products/images/outofstock-20.png" class="instock" style="height:20px;vertical-align:middle" alt="Nintendo Switch with Neon Joy-Con is out of Stock"><BR></p><p><B><a href='https://www.i4u.com/thetracker/products/tracker-33.html'>Nintendo Switch Walmart Bundle</a></b>  <img src="https://static2.i4u.com/thetracker/products/images/outofstock-20.png" class="instock" style="height:20px;vertical-align:middle" alt="Nintendo Switch Walmart Bundle is out of Stock"><BR></p><p><B><a href='https://www.i4u.com/thetracker/products/tracker-45.html'>LEGO Ideas NASA Apollo Saturn V Set</a></b>  <img src="https://static2.i4u.com/thetracker/products/images/outofstock-20.png" class="instock" style="height:20px;vertical-align:middle" alt="LEGO Ideas NASA Apollo Saturn V Set is out of Stock"><BR></p><p><B><a href='https://www.i4u.com/thetracker/products/tracker-61.html'>Xbox One X</a></b>  <img src="https://static2.i4u.com/thetracker/products/images/outofstock-20.png" class="instock" style="height:20px;vertical-align:middle" alt="Xbox One X is out of Stock"><BR></p><p><B><a href='https://www.i4u.com/thetracker/products/tracker-73.html'>LEGO Boost Creative Toolbox 17101</a></b>  <img src="https://static2.i4u.com/thetracker/products/images/preorder-20.png" class="instock" style="height:20px;vertical-align:middle" alt="LEGO Boost Creative Toolbox 17101 is available for Pre-order"><BR></p><p><B><a href='https://www.i4u.com/thetracker/products/tracker-74.html'>Nintendo Switch Pro Controller Splatoon 2 Edition</a></b>  <img src="https://static2.i4u.com/thetracker/products/images/outofstock-20.png" class="instock" style="height:20px;vertical-align:middle" alt="Nintendo Switch Pro Controller Splatoon 2 Edition is out of Stock"><BR></p><p><B><a href='https://www.i4u.com/thetracker/products/tracker-81.html'>Super Nintendo SNES Classic</a></b>  <img src="https://static2.i4u.com/thetracker/products/images/outofstock-20.png" class="instock" style="height:20px;vertical-align:middle" alt="Super Nintendo SNES Classic is out of Stock"><BR></p><p><B><a href='https://www.i4u.com/thetracker/products/tracker-88.html'>Nintendo Switch w/Gray Joy-Con Ultimate Fan Bundle</a></b>  <img src="https://static2.i4u.com/thetracker/products/images/instock-20.png" class="instock" style="height:20px;vertical-align:middle" alt="Nintendo Switch w/Gray Joy-Con Ultimate Fan Bundle is in Stock"><BR></p>		
</div>  	
<BR>
	
	<BR>
			
<div style="width:300px;">
<a href="https://www.i4u.com/2017/06/123229/win-free-nintendo-switch-console-tracker-i4u-news-summer-giveaway"><img src="http://static2.i4u.com/thetracker/win-nintendo-switch-free.jpg" width="300" height="171" alt="Enter to Win a Nintendo Switch Bundle Valued at $500"></a>
</div>		
<BR>
			
		</div>
		<!-- /sidebar -->
	</div>
</div>



  
<div style="width:100%;height:90px;">
<center>
<div id='i4u-footer'>
<script>
googletag.cmd.push(function() { googletag.display('i4u-footer'); });
</script>
</div>
</center>
</div>



				<div class="one-third column alpha">	
					<h3 class="impactHeader">
						<span class="impactHeader-bg">News by Section</span>
					</h3>
					<ul>	

						
						<li><a href="https://www.i4u.com/47/technology-news">Technology News</a></li>
						<li><a href="https://www.i4u.com/51/apple">Apple News</a></li>
						<li><a href="https://www.i4u.com/92652/latest-science-news">Science News</a></li>
						<li><a href="https://www.i4u.com/72447/latest-celebrity-news">Celebrity News</a></li>	
						<li><a href="https://www.i4u.com/72449/latest-movie-news">Movie News</a></li>
					
						<li><a href="https://www.i4u.com/55/cars-vehicles">Car News</a></li>
						<li><a href="https://www.i4u.com/72457/latest-business-news">Business News</a></li>
						<li><a href="https://www.i4u.com/72459/latest-political-news">Political News</a></li>
						<li><a href="https://www.i4u.com/71857/latest-sports-news">Sport News</a></li>
						<li><a href="https://www.i4u.com/72460/latest-tv-news">TV Show News</a></li>		
						<li><a href="https://www.i4u.com/51729/also-geek-mind">Also on the Geek Mind</a></li>
						<li><a href="https://www.i4u.com/72448/advertising-news">Advertising News</a></li>	
						<li><a href="https://www.i4u.com/54/black-friday">Black Friday 2017</a></li>
						<li><a href="https://www.i4u.com/57536/cyber-monday">Cyber Monday 2017</A></li>   
						<li><a href="https://www.i4u.com/62/holiday-gift-guide">Holiday Gifts 2017</a></li>		
						<li><a href="https://www.i4u.com/57/ces">CES 2017</a></li>
						<li><a href="https://www.i4u.com/70/super-bowl">Super Bowl 2017 Ads</A></li>
						
					</ul>		
					
				</div>
				<div class="one-third column latestLinks-middleCol">
				
					<h3 class="impactHeader">
						<span class="impactHeader-bg">About I4U News</span>
					</h3>
					<p>I4U News is daily News site for the Geek Mind. Expect the latest technology news including the juiciest rumors. Stay up to date with the biggest discoveries in science. Other featured news topics include cars, celebrities, movies and more. <B><a href="http://www.i4u.com/about/about-us">Read more</a></b>.</p>
					
					
					
				</div>
				<div class="one-third column omega">
					<h3 class="impactHeader">
						<span class="impactHeader-bg">Amazon Prime Day 2017</span>
					</h3>
					
<ul>	

<li><a href="https://www.i4u.com/2017/04/122123/amazon-prime-day-2017-date-deals-and-everything-you-need-know">Amazon Prime Day 2017 Details</a></li>
<li><a href="https://www.i4u.com/2017/05/122791/prime-day-2017-deals-list-tracker">Amazon Prime Day 2017 Deals</a></li>
<li><a href="https://www.i4u.com/2017/06/123422/amazon-prime-day-2017-best-shopping-tools-hunt-prime-day-deals">Amazon Prime Day 2017 Tools</a></li>
<li><a href="https://www.i4u.com/tag/prime">Read the Latest Prime Day 2017 News</a></li>

</ul>		
								
	
			
				</div>
	
				<div class="clear"></div>			
				<div id="Footer">
		<div id="FooterInner"> 
			
<div id="block-block-2" class=""><div class="block-inner">

  
  <div class="content">
    <div>
<div style="float: left; width: 300px;">
<div id="Search" class="Right"> 
			
		<form action="/search" id="searchbox_001713751604670860039:oyclnxhhcfo">
				<input type="hidden" name="cx" value="001713751604670860039:oyclnxhhcfo" />
				<input type="hidden" name="cof" value="FORID:11" />
				<input name="as_q" type="text" autocomplete="on" class="textfieldLg" />
				<input type="submit" style="border:0px;" id="search_btn" height="24" border="0" width="80" class="btn" alt="" src="" name="sa" />
			</form>
		</div>
</div>
<div style="overflow: hidden;float:right;">
<a href="/about/about-us">About Us</a> | 
<a href="/about/privacy-policy">Privacy Policy</a> | 
<a href="mailto:i4u@i4u.com?subject=News Tip: ">Submit News Tips</a>
<br />
&copy; Copyright by I4U LLC 2017 

</div>

</div>
<br />  </div>

  
</div></div> <!-- /block-inner, /block -->
 
			
			

			
			
		</div>
	</div>		
	
				<span class="mrf-hide">
		
			<div class="mrf-hide" style="height:40px;line-height:40px;margin:0px;background-color:#f5f5f5;">
			<div class="mrf-hide" style="float:left;width:100px;vertical-align: middle;text-align: center;">
			<B>Follow Us</B>
			</div>
				<div  style="float:left;width:160px;vertical-align: middle;text-align: center;">
			<a href="https://twitter.com/i4unews" target="_blank"><img src="https://static2.i4u.com/sites/default/files/images/content_images/twitter-2015.jpg" width="143" height="28" style="vertical-align: middle;"  Alt="Follow I4U News on Twitter"></a>

</div>
	<div style="float:left;width:91px;vertical-align: middle;text-align: center;">
<a href="https://www.facebook.com/i4unewscommunity" target="_blank"><img src="https://static2.i4u.com/sites/default/files/images/content_images/facebook-2015.jpg" width="84" height="28" style="vertical-align: middle;" Alt="Follow I4U News on Facebook"></a>
</div>		
<div style="float:left;width:500px;vertical-align: middle;text-align: center;">

			<Center><B><a href="https://www.i4u.com/about/subscribe" target="_blank">Click to Receive I4U News via Email</A></B></center>
	</div>		

</div>
</span>
	
			
			</div>		
		</div>
	</div>
</div>


<noscript id="deferred-styles">
<link rel="stylesheet" type="text/css" href="https://static2.i4u.com/sites/all/themes/i4u/css/styles.css" /> 
</noscript>
    <script>
      var loadDeferredStyles = function() {
        var addStylesNode = document.getElementById("deferred-styles");
        var replacement = document.createElement("div");
        replacement.innerHTML = addStylesNode.textContent;
        document.body.appendChild(replacement)
        addStylesNode.parentElement.removeChild(addStylesNode);
      };
      var raf = requestAnimationFrame || mozRequestAnimationFrame ||
          webkitRequestAnimationFrame || msRequestAnimationFrame;
      if (raf) raf(function() { window.setTimeout(loadDeferredStyles, 0); });
      else window.addEventListener('load', loadDeferredStyles);
    </script>
<script type="text/javascript">
function downloadJSAtOnload() {
	(function(scripts) {
	 	var i = 0,
	 		l = scripts.length;
		for (; i<l; ++i ){
			var element = document.createElement("script");
			element.src = scripts[i];
			document.body.appendChild(element);
		}
	})(['https://static1.i4u.com/sites/all/themes/i4u/js/defer.js']);
}
 
if (window.addEventListener)
        window.addEventListener("load", downloadJSAtOnload, false);
else if (window.attachEvent)
	window.attachEvent("onload", downloadJSAtOnload);
else window.onload = downloadJSAtOnload;
</script>
 

 

<script type="text/javascript" id="dsq-count-scr" src="//i4unews.disqus.com/count.js" async></script>



 


</body>
</html>
<!-- Page cached by Boost @ 2017-07-06 08:52:52, expires @ 2017-07-06 11:52:52 -->
